Finally, Plesk 12 supports multiple PHP versions out of the box!

Multiple versions

Today I noticed that Plesk 12 since micro update 41 can install PHP 5.2 up to 5.6 7.0 via the built-in installer, this makes the scripts I made obsolete.

If you are still running 11.5 Parallels (or Odin Plesk) also put up official guides telling you how to install php 5.6 wich can be modified to install most versions.

Don’t believe me? Go and see for yourself: http://kb.odin.com/en/118378